<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-GB"> <!--<![endif]-->
<head>
    <title>Are DPUs ready for the data centre mainstream? &ndash; Blocks and Files</title>
    <meta charset="UTF-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0">
    <link rel="pingback" href="https://blocksandfiles.com/xmlrpc.php" />
	
	
	
	<!-- BEGIN GAM SETUP -->

    <script src="//securepubads.g.doubleclick.net/tag/js/gpt.js"></script>
    <script src="https://nir.theregister.co.uk/?g=c&amp;g=sa&amp;s=c/baf.all"></script>
	
    <script>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</script>	
	
	<!-- END GAM SETUP -->
	
	
	
	
	
	
	
	
	
	
    <meta property="og:image" content="https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture.jpg" /><link rel="icon" type="image/png" href="https://blocksandfiles.com/wp-content/uploads/2018/10/BANDF_Finalised-logo_icon.png">
<!-- This site is optimized with the Yoast SEO plugin v12.9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/" />
<meta property="og:locale" content="en_GB" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Are DPUs ready for the data centre mainstream? &ndash; Blocks and Files" />
<meta property="og:description" content="The X86 CPU is a general purpose processing marvel but it is poor at handling the repetitive processing of billions of instructions. Dedicated parallelised hardware such as Nvidia’s GPUs accelerate these operations. Other suppliers are pursuing this specialised processing hardware idea with dedicated storage and networking processors called Data Processing Units (DPU). As the volume &hellip;" />
<meta property="og:url" content="https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/" />
<meta property="og:site_name" content="Blocks and Files" />
<meta property="article:tag" content="Arm" />
<meta property="article:tag" content="AWS" />
<meta property="article:tag" content="Diamanti" />
<meta property="article:tag" content="Fungible Inc." />
<meta property="article:tag" content="Pensando" />
<meta property="article:section" content="Data Management" />
<meta property="article:published_time" content="2020-05-26T11:07:44+00:00" />
<meta property="article:modified_time" content="2020-05-26T14:33:30+00:00" />
<meta property="og:updated_time" content="2020-05-26T14:33:30+00:00" />
<meta property="og:image" content="https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture.jpg" />
<meta property="og:image:secure_url" content="https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture.jpg" />
<meta property="og:image:width" content="950" />
<meta property="og:image:height" content="531" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The X86 CPU is a general purpose processing marvel but it is poor at handling the repetitive processing of billions of instructions. Dedicated parallelised hardware such as Nvidia’s GPUs accelerate these operations. Other suppliers are pursuing this specialised processing hardware idea with dedicated storage and networking processors called Data Processing Units (DPU). As the volume [&hellip;]" />
<meta name="twitter:title" content="Are DPUs ready for the data centre mainstream? &ndash; Blocks and Files" />
<meta name="twitter:image" content="https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture.jpg" />
<meta name="twitter:creator" content="@Chris_Mellor" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://blocksandfiles.com/#organization","name":"Situation Publishing","url":"https://blocksandfiles.com/","sameAs":[],"logo":{"@type":"ImageObject","@id":"https://blocksandfiles.com/#logo","url":"https://blocksandfiles.com/wp-content/uploads/2018/10/Logo-SP_horizontal_black.png","width":543,"height":267,"caption":"Situation Publishing"},"image":{"@id":"https://blocksandfiles.com/#logo"}},{"@type":"WebSite","@id":"https://blocksandfiles.com/#website","url":"https://blocksandfiles.com/","name":"Blocks and Files","description":"Where Storage Lives","publisher":{"@id":"https://blocksandfiles.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://blocksandfiles.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/#primaryimage","url":"https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture.jpg","width":950,"height":531},{"@type":"WebPage","@id":"https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/#webpage","url":"https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/","inLanguage":"en-GB","name":"Are DPUs ready for the data centre mainstream? &ndash; Blocks and Files","isPartOf":{"@id":"https://blocksandfiles.com/#website"},"primaryImageOfPage":{"@id":"https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/#primaryimage"},"datePublished":"2020-05-26T11:07:44+00:00","dateModified":"2020-05-26T14:33:30+00:00"},{"@type":"Article","@id":"https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/#article","isPartOf":{"@id":"https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/#webpage"},"author":{"@id":"https://blocksandfiles.com/#/schema/person/33f6d3f11622c0df605a26362b2b8fe3"},"headline":"Are DPUs ready for the data centre mainstream?","datePublished":"2020-05-26T11:07:44+00:00","dateModified":"2020-05-26T14:33:30+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/#webpage"},"publisher":{"@id":"https://blocksandfiles.com/#organization"},"image":{"@id":"https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/#primaryimage"},"keywords":"Arm,AWS,Diamanti,Fungible Inc.,Pensando","articleSection":"Data Management"},{"@type":["Person"],"@id":"https://blocksandfiles.com/#/schema/person/33f6d3f11622c0df605a26362b2b8fe3","name":"Chris Mellor","description":"Chris Mellor is the founder of Blocks &amp; Files and the storage editor of its sister title The Register. He has reported and analysed IT storage matters for 20 years, starting out in the industry coding for mainframes, then installing mini-computer software and enjoying using PDP-8 tapes and early removable DEC disk drives.","sameAs":["https://www.linkedin.com/in/chris-mellor-5776242/","https://twitter.com/https://twitter.com/Chris_Mellor"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Blocks and Files &raquo; Feed" href="https://blocksandfiles.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blocks and Files &raquo; Comments Feed" href="https://blocksandfiles.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Blocks and Files &raquo; Are DPUs ready for the data centre mainstream? Comments Feed" href="https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-33330076-15';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-33330076-15', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/blocksandfiles.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://blocksandfiles.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://blocksandfiles.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300italic%2C400%2C400italic%2C600%2C600italic%2C700%7CRoboto%3A300%2C400%2C400italic%2C500%2C500italic%2C700%2C900%2C600&#038;ver=8.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css'  href='https://blocksandfiles.com/wp-content/themes/Newspaper/style.css?ver=8.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-demo-style-css'  href='https://blocksandfiles.com/wp-content/themes/Newspaper/includes/demos/lifestyle/demo_style.css?ver=8.7.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/blocksandfiles.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blocksandfiles.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.4'></script>
<script type='text/javascript' src='https://blocksandfiles.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://blocksandfiles.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://blocksandfiles.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://blocksandfiles.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://blocksandfiles.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://blocksandfiles.com/?p=16386' />
<link rel="alternate" type="application/json+oembed" href="https://blocksandfiles.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblocksandfiles.com%2F2020%2F05%2F26%2Fdata-processor-unit-dpu-overview%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://blocksandfiles.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fblocksandfiles.com%2F2020%2F05%2F26%2Fdata-processor-unit-dpu-overview%2F&#038;format=xml" />
			<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/blocksandfiles.com\/wp-admin\/","wpRestNonce":"6ac135164d","wpRestUrl":"https:\/\/blocksandfiles.com\/wp-json\/","permalinkStructure":"\/%year%\/%monthnum%\/%day%\/%postname%\/"};
			</script>
			<!--[if lt IE 9]><script src="https://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]-->
    
<!-- JS generated by theme -->

<script>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</script>


<!-- Header style compiled by theme -->

<style>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</style>

<script type="application/ld+json">
                        {
                            "@context": "http://schema.org",
                            "@type": "BreadcrumbList",
                            "itemListElement": [{
                            "@type": "ListItem",
                            "position": 1,
                                "item": {
                                "@type": "WebSite",
                                "@id": "https://blocksandfiles.com/",
                                "name": "Home"                                               
                            }
                        },{
                            "@type": "ListItem",
                            "position": 2,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://blocksandfiles.com/category/data-management/",
                                "name": "Data Management"
                            }
                        },{
                            "@type": "ListItem",
                            "position": 3,
                                "item": {
                                "@type": "WebPage",
                                "@id": "https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/",
                                "name": "Are DPUs ready for the data centre mainstream?"                                
                            }
                        }    ]
                        }
                       </script>	<style id="tdw-css-placeholder"></style></head>

<body class="post-template-default single single-post postid-16386 single-format-standard data-processor-unit-dpu-overview global-block-template-8 td-lifestyle single_template_5 td-animation-stack-type0 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">

        <div class="td-scroll-up"><i class="td-icon-menu-up"></i></div>
    
    <div class="td-menu-background"></div>
<div id="td-mobile-nav">
    <div class="td-mobile-container">
        <!-- mobile menu top section -->
        <div class="td-menu-socials-wrap">
            <!-- socials -->
            <div class="td-menu-socials">
                
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://blocksandfiles.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/blocksandfiles/" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>            </div>
            <!-- close button -->
            <div class="td-mobile-close">
                <a href="#"><i class="td-icon-close-mobile"></i></a>
            </div>
        </div>

        <!-- login section -->
        
        <!-- menu section -->
        <div class="td-mobile-content">
            <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu" class="td-mobile-main-menu"><li id="menu-item-39" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-39"><a href="https://blocksandfiles.com/">Home</a></li>
<li id="menu-item-443" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-443"><a href="https://blocksandfiles.com/block/">Block</a></li>
<li id="menu-item-444" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-444"><a href="https://blocksandfiles.com/file/">File</a></li>
<li id="menu-item-445" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-445"><a href="https://blocksandfiles.com/object/">Object</a></li>
<li id="menu-item-446" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-446"><a href="https://blocksandfiles.com/disk/">Disk</a></li>
<li id="menu-item-447" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-447"><a href="https://blocksandfiles.com/tape/">Tape</a></li>
<li id="menu-item-448" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-448"><a href="https://blocksandfiles.com/flash/">Flash</a></li>
<li id="menu-item-449" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-449"><a href="https://blocksandfiles.com/nvme/">NVMe</a></li>
<li id="menu-item-450" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-450"><a href="https://blocksandfiles.com/scm/">SCM</a></li>
<li id="menu-item-451" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-451"><a href="https://blocksandfiles.com/hci/">HCI</a></li>
<li id="menu-item-455" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-455"><a href="https://blocksandfiles.com/composable/">Composable</a></li>
</ul></div>        </div>
    </div>

    <!-- register/login section -->
    </div>    <div class="td-search-background"></div>
<div class="td-search-wrap-mob">
	<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
		<form method="get" class="td-search-form" action="https://blocksandfiles.com/">
			<!-- close button -->
			<div class="td-search-close">
				<a href="#"><i class="td-icon-close-mobile"></i></a>
			</div>
			<div role="search" class="td-search-input">
				<span>Search</span>
				<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
			</div>
		</form>
		<div id="td-aj-search-mob"></div>
	</div>
</div>    
    
    <div id="td-outer-wrap" class="td-theme-wrap">
    
        <!--
Header style 10
-->

<div class="td-header-wrap td-header-style-10 ">
    
	<div class="td-header-top-menu-full td-container-wrap ">
		<div class="td-container td-header-row td-header-top-menu">
            
    <div class="top-bar-style-1">
        
<div class="td-header-sp-top-menu">


	<div class="menu-top-container"><ul id="menu-td-demo-top-menu" class="top-header-menu"><li id="menu-item-401" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-401"><a href="https://blocksandfiles.com/newsletter-sign-up/">Newsletter</a></li>
<li id="menu-item-402" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-402"><a href="https://blocksandfiles.com/archive/">Archive</a></li>
<li id="menu-item-13469" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-13469"><a href="https://blocksandfiles.com/about/">About</a></li>
</ul></div></div>
        <div class="td-header-sp-top-widget">
    
    
        
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://blocksandfiles.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/blocksandfiles/" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span>    </div>    </div>

<!-- LOGIN MODAL -->
		</div>
	</div>

    <div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap ">
        <div class="td-header-sp-logo">
            			<a class="td-main-logo" href="https://blocksandfiles.com/">
				<img src="https://blocksandfiles.com/wp-content/uploads/2018/10/BF-black-300x92.png" alt=""/>
				<span class="td-visual-hidden">Blocks and Files</span>
			</a>
		        </div>
    </div>

	<div class="td-header-menu-wrap-full td-container-wrap ">
        
        <div class="td-header-menu-wrap td-header-gradient ">
			<div class="td-container td-header-row td-header-main-menu">
				<div id="td-header-menu" role="navigation">
    <div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
    <div class="td-main-menu-logo td-logo-in-header">
        		<a class="td-mobile-logo td-sticky-disable" href="https://blocksandfiles.com/">
			<img src="https://blocksandfiles.com/wp-content/uploads/2018/10/BF-white-300x92.png" alt=""/>
		</a>
			<a class="td-header-logo td-sticky-disable" href="https://blocksandfiles.com/">
			<img src="https://blocksandfiles.com/wp-content/uploads/2018/10/BF-black-300x92.png" alt=""/>
		</a>
	    </div>
    <div class="menu-td-demo-header-menu-container"><ul id="menu-td-demo-header-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-39"><a href="https://blocksandfiles.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-443"><a href="https://blocksandfiles.com/block/">Block</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-444"><a href="https://blocksandfiles.com/file/">File</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-445"><a href="https://blocksandfiles.com/object/">Object</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-446"><a href="https://blocksandfiles.com/disk/">Disk</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-447"><a href="https://blocksandfiles.com/tape/">Tape</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-448"><a href="https://blocksandfiles.com/flash/">Flash</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-449"><a href="https://blocksandfiles.com/nvme/">NVMe</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-450"><a href="https://blocksandfiles.com/scm/">SCM</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-451"><a href="https://blocksandfiles.com/hci/">HCI</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-455"><a href="https://blocksandfiles.com/composable/">Composable</a></li>
</ul></div></div>


    <div class="header-search-wrap">
        <div class="td-search-btns-wrap">
            <a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
            <a id="td-header-search-button-mob" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
        </div>

        <div class="td-drop-down-search" aria-labelledby="td-header-search-button">
            <form method="get" class="td-search-form" action="https://blocksandfiles.com/">
                <div role="search" class="td-head-form-search-wrap">
                    <input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
                </div>
            </form>
            <div id="td-aj-search"></div>
        </div>
    </div>
			</div>
		</div>
	</div>

            <div class="td-banner-wrap-full td-banner-bg td-container-wrap ">
            <div class="td-container-header td-header-row td-header-header">
                <div class="td-header-sp-recs">
                    <div class="td-header-rec-wrap">
    <div class="td-a-rec td-a-rec-id-header  td_uid_1_5eceba2c45df8_rand td_block_template_8"><div id=ad-kite class=adu>
<script>
  show_gpt('ad-kite');
</script>
</div>

<div id=ad-condor class=adu>
<script>
  show_gpt('ad-condor');
</script>
</div></div>
</div>                </div>
            </div>
        </div>
    
</div><div class="td-main-content-wrap td-container-wrap">

    <div class="td-container td-post-template-5 ">
        <div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://blocksandfiles.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Data Management" class="entry-crumb" href="https://blocksandfiles.com/category/data-management/">Data Management</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Are DPUs ready for the data centre mainstream?</span></div></div>
            <div class="td-pb-row">
                                            <div class="td-pb-span8 td-main-content" role="main">
                                <div class="td-ss-main-content">
                                    
    <article id="post-16386" class="post-16386 post type-post status-publish format-standard has-post-thumbnail hentry category-data-management tag-arm tag-aws tag-diamanti tag-fungible-inc tag-pensando" itemscope itemtype="https://schema.org/Article">
        <div class="td-post-header">

            <ul class="td-category"><li class="entry-category"><a  href="https://blocksandfiles.com/category/data-management/">Data Management</a></li></ul>
            <header class="td-post-title">
                <h1 class="entry-title">Are DPUs ready for the data centre mainstream?</h1>

                

                <div class="td-module-meta-info">
                    <div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://blocksandfiles.com/author/chris-mellor/">Chris Mellor</a><div class="td-author-line"> - </div> </div>                    <span class="td-post-date td-post-date-no-dot"><time class="entry-date updated td-module-date" datetime="2020-05-26T11:07:44+00:00" >May 26, 2020</time></span>                                                        </div>

            </header>

        </div>

        <div class="td-post-sharing-top"><div id="td_uid_2_5eceba2c465d0" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Are+DPUs+ready+for+the+data+centre+mainstream%3F&url=https%3A%2F%2Fblocksandfiles.com%2F2020%2F05%2F26%2Fdata-processor-unit-dpu-overview%2F&via=Blocks+and+Files">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Are DPUs ready for the data centre mainstream? %0A%0A https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/&title=Are DPUs ready for the data centre mainstream?">
                                        <div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
                                        <div class="td-social-but-text">Linkedin</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/&title=Are DPUs ready for the data centre mainstream?">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Are DPUs ready for the data centre mainstream?&body=https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_uid_2_5eceba2c465d0">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>

        <div class="td-post-content">
            
<p>The X86 CPU is a general purpose processing marvel but it is poor at handling the repetitive processing of billions of instructions. Dedicated parallelised hardware such as Nvidia’s GPUs accelerate these operations.</p>



<p>Other suppliers are pursuing this specialised processing hardware idea with dedicated storage and networking processors called Data Processing Units (DPU).</p>



<p>As the volume of data stored and sent over networks by enterprises <a href="https://blocksandfiles.com/2020/05/14/idc-disk-drives-will-store-over-half-world-data-in-2024/">carries on rising</a>, DPU developers are betting that their products will be needed to accelerate storage and networking functions carried out by industry standard servers. These DPUs can be based on different kinds of processing hardware &#8211; for example, ASICs, FPGAs and SoCS with customised Arm CPUs.&nbsp;</p>



<p>In a recent blog, Kevin Deierling, an SVP at Mellanox, a Nvidia subsidiary, argues that <a href="https://blogs.nvidia.com/blog/2020/05/20/whats-a-dpu-data-processing-unit/">the DPU</a> has &#8220;become the third member of the data centric accelerated computing model [where] the CPU is for general purpose computing, the GPU is for accelerated computing and the DPU, which moves data around the data centre, does data processing&#8221;.</p>



<figure class="wp-block-image size-large"><img src="https://blocksandfiles.com/wp-content/uploads/2020/05/Pensando-DSC-cards-in-severs.jpg" alt="" class="wp-image-16390" srcset="https://blocksandfiles.com/wp-content/uploads/2020/05/Pensando-DSC-cards-in-severs.jpg 513w, https://blocksandfiles.com/wp-content/uploads/2020/05/Pensando-DSC-cards-in-severs-237x300.jpg 237w, https://blocksandfiles.com/wp-content/uploads/2020/05/Pensando-DSC-cards-in-severs-331x420.jpg 331w" sizes="(max-width: 513px) 100vw, 513px" /><figcaption>Pensando DPUs deployed in servers.</figcaption></figure>



<div class="td-a-rec td-a-rec-id-content_inlineright  td_uid_3_5eceba2c4734d_rand td_block_template_8"><div id=ad-falcon class=adu>
<script>
  show_gpt('ad-falcon');
</script>
</div></div><p>A DPU is a system on a chip (SoC), containing three elements, according to Deierling.</p>



<ul><li>Multi-core CPU, e.g. Arm</li><li>Network interface capable of parsing, processing and transferring data at line rate &#8211; or at the speed of the rest of the network &#8211; to GPUs and CPUs,</li><li>Set of acceleration engines that offload and improve applications performance for AI and machine learning, security, telecommunications, and storage, among others.</li></ul>



<p>Dieirling reveals his Mellanox bias with this statement: “The DPU can be used as a stand-alone embedded processor, but it’s more often incorporated into a <a href="https://blog.mellanox.com/2018/08/defining-dpu-smartnic/">SmartNic</a>, a network interface controller,” such as Mellanox products.  A SmartNIC carries out network traffic data processing, unlike a standard NIC where the CPU handles much of the workload. So, Deierling is making the point here that DPUs offload a host X86 CPU.</p>



<h2>Arm DPU ideas</h2>



<p>Several storage-focused DPU products using Arm chips have recently arrived on the scene. Wells Fargo senior analyst Aaron Rakers explained Arm’s DPU ideas to subscribers. He says Chris Bergey, Arm SVP for infrastructure, “shares Nvidia’s vision of the datacenter as a single compute engine (CPU + GPU + DPU). He noted the company is focused on offloading data from the processor via SmartNICs and on the use of data lakes. We continue to see an Nvidia Arm CPU in the datacenter as an intriguing possibility.”</p>



<p>He adds: “As Nvidia looks to integrate / leverage Mellanox, a long-time user of Arm, we question whether Nvidia could be on a path to further deepen / develop their use of Arm for datacenter solutions going forward.&#8221;</p>



<p>Let&#8217;s have a look at some of the DPU players, starting with AWS.</p>



<h2>AWS Nitro</h2>



<p>Amazon Web Services has decomposed traditional servers, adding Nitro IO acceleration cards (ASICs) to handle VPC (Virtual Private Cloud), EBS, Instance Storage, security and more with an overall Nitro Card Controller. </p>



<p>An AWS Elastic Compute Cloud instance is based on PCIe-connected Nitro cards plus X86 or Arm processors and DRAM. There are various EC2 instance types &#8211; either general purpose or optimised for compute, memory, storage, machine learning and scale-out use cases.</p>



<figure class="wp-block-image size-large"><img src="https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture.jpg" alt="" class="wp-image-16388" srcset="https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture.jpg 950w, https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture-300x168.jpg 300w, https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture-768x429.jpg 768w, https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture-696x389.jpg 696w, https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture-751x420.jpg 751w" sizes="(max-width: 950px) 100vw, 950px" /><figcaption>AWS Nitro architecture slide</figcaption></figure>



<h2>Diamanti</h2>



<p>Diamanti is developing bare-metal hyperconverged server hardware to run Kubernetes-orchestrated containers more efficiently that standard servers. Diamanti D10, D20 and G20 servers are fitted with Ultima-branded network and storage offload cards &#8211; DPUs with PCIe interfaces.</p>



<figure class="wp-block-image size-large"><img src="https://blocksandfiles.com/wp-content/uploads/2020/03/Diamante-D10-diagram.jpg" alt="" class="wp-image-14583" srcset="https://blocksandfiles.com/wp-content/uploads/2020/03/Diamante-D10-diagram.jpg 650w, https://blocksandfiles.com/wp-content/uploads/2020/03/Diamante-D10-diagram-300x149.jpg 300w, https://blocksandfiles.com/wp-content/uploads/2020/03/Diamante-D10-diagram-324x160.jpg 324w" sizes="(max-width: 650px) 100vw, 650px" /><figcaption>Diamanti D10 server&#8217;s offload cards.</figcaption></figure>



<p>They offload storage and networking traffic from the server&#8217;s Xeon CPUs to their dedicated processors, which have hardware-based queues.</p>



<p>The network card has a 40GbitE QSFP controller and is Kubernetes CNI and SR-IOV-enabled. It links the server to a switched infrastructure. The controller can integrate with standard enterprise data centre networking topologies, delivering overlay and non-overlay network interfaces, static and dynamic IP assignment and support for multiple interfaces per Kubernetes pod.</p>



<p>The storage card links the server to an NVMe storage infrastructure. It is an NVMe controller and Kubernetes CSI-enabled with data protection and disaster recovery features such mirroring, snapshots, multi-cluster asynchronous replication, and backup and recovery. Replication is based on changed snapshot-blocks to reduce network traffic.  </p>



<p>Both cards have Quality-of-Service features to ensure storage IOPS and network throughput consistency.</p>



<h2>Fungible Inc</h2>



<p>Startup <a href="https://blocksandfiles.com/2020/02/11/fungible-inc-composable-dpu-microprocessor/">Fungible Inc is developing a DPU </a>that can compose server components and accelerate server IO.</p>



<div class="wp-block-image"><figure class="aligncenter size-large is-resized"><img src="https://blocksandfiles.com/wp-content/uploads/2020/02/DPU-diagram.jpg" alt="" class="wp-image-13415" width="488" height="323" srcset="https://blocksandfiles.com/wp-content/uploads/2020/02/DPU-diagram.jpg 650w, https://blocksandfiles.com/wp-content/uploads/2020/02/DPU-diagram-300x198.jpg 300w, https://blocksandfiles.com/wp-content/uploads/2020/02/DPU-diagram-635x420.jpg 635w" sizes="(max-width: 488px) 100vw, 488px" /><figcaption>Fungible DPU diagram.</figcaption></figure></div>



<p>According to Fungible, network and DPU devices can perform data-centric work better than general-purpose server CPUs. Dedicate them to application processing and have the DPUs look after the storage, security and network IO grunt work.</p>



<p>This startup is expected to formally launch product later this year.</p>



<h2>Pensando</h2>



<p>Pensando makes dedicated customisable P4 Capri processors which are located at a server’s edge; the place where it talks to networks and storage. They run a software stack delivering network, storage, and security services at cloud scale with claimed minimal latency, jitter and low power requirements.&nbsp;</p>



<p>A <a href="https://blocksandfiles.com/2019/11/01/pensando-software-defined-network-card-more-details/">Pensando Distributed Services Card</a> (DSC-100) is installed in a host server to deliver the Capri processor hardware and software functions. This DSC-100 effectively combines the functionality of Diamanti’s separate network and storage cards.</p>



<figure class="wp-block-image size-large"><img src="https://blocksandfiles.com/wp-content/uploads/2020/05/Pensando-DSC-100-PCIe-card.jpg" alt="" class="wp-image-16387" srcset="https://blocksandfiles.com/wp-content/uploads/2020/05/Pensando-DSC-100-PCIe-card.jpg 950w, https://blocksandfiles.com/wp-content/uploads/2020/05/Pensando-DSC-100-PCIe-card-300x235.jpg 300w, https://blocksandfiles.com/wp-content/uploads/2020/05/Pensando-DSC-100-PCIe-card-768x602.jpg 768w, https://blocksandfiles.com/wp-content/uploads/2020/05/Pensando-DSC-100-PCIe-card-696x546.jpg 696w, https://blocksandfiles.com/wp-content/uploads/2020/05/Pensando-DSC-100-PCIe-card-536x420.jpg 536w" sizes="(max-width: 950px) 100vw, 950px" /></figure>



<h2><strong>Comment</strong></h2>



<p>None of the DPUs above can be classed as industry-standard. Unless included in a server or storage array on an OEM basis, they require separate purchase, management and support arrangements and add complexity. Therefore, the best scenario for enterprise customers is for the mainstream suppliers to treat DPUs as just another component to incorporate into their own systems. Also, we can think about Intel&#8217;s views here. The chipmaker already makes Ethernet switch silicon and Altera FPGAs and may be keen to protect its data centre silicon footprint from DPU interlopers.</p>



<p>Hyperscaler customers are a different story as they have the scale to buy direct from DPU suppliers and get DPUs customised for their needs. AWS Nitro ASICs are a classic example of this.</p>
<div class="td-a-rec td-a-rec-id-content_bottom  td_uid_4_5eceba2c474b9_rand td_block_template_8"><span class="td-adspot-title">- Advertisement - </span><div id=ad-hawk class=adu>
<script>
  show_gpt('ad-hawk');
</script>
</div></div>        </div>


        <footer>
                        
            <div class="td-post-source-tags">
                                <ul class="td-tags td-post-small-box clearfix"><li><span>TAGS</span></li><li><a href="https://blocksandfiles.com/tag/arm/">Arm</a></li><li><a href="https://blocksandfiles.com/tag/aws/">AWS</a></li><li><a href="https://blocksandfiles.com/tag/diamanti/">Diamanti</a></li><li><a href="https://blocksandfiles.com/tag/fungible-inc/">Fungible Inc.</a></li><li><a href="https://blocksandfiles.com/tag/pensando/">Pensando</a></li></ul>            </div>

            <div class="td-post-sharing-bottom"><div class="td-post-sharing-classic"><iframe frameBorder="0" src="https://www.facebook.com/plugins/like.php?href=https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/&amp;layout=button_count&amp;show_faces=false&amp;width=105&amp;action=like&amp;colorscheme=light&amp;height=21" style="border:none; overflow:hidden; width:105px; height:21px; background-color:transparent;"></iframe></div><div id="td_uid_5_5eceba2c4778d" class="td-post-sharing td-ps-bg td-ps-notext td-ps-rounded td-post-sharing-style3 "><div class="td-post-sharing-visible"><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Are+DPUs+ready+for+the+data+centre+mainstream%3F&url=https%3A%2F%2Fblocksandfiles.com%2F2020%2F05%2F26%2Fdata-processor-unit-dpu-overview%2F&via=Blocks+and+Files">
                                        <div class="td-social-but-icon"><i class="td-icon-twitter"></i></div>
                                        <div class="td-social-but-text">Twitter</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="whatsapp://send?text=Are DPUs ready for the data centre mainstream? %0A%0A https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/">
                                        <div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div>
                                        <div class="td-social-but-text">WhatsApp</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/&title=Are DPUs ready for the data centre mainstream?">
                                        <div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div>
                                        <div class="td-social-but-text">Linkedin</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/&title=Are DPUs ready for the data centre mainstream?">
                                        <div class="td-social-but-icon"><i class="td-icon-reddit"></i></div>
                                        <div class="td-social-but-text">ReddIt</div>
                                    </a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="mailto:?subject=Are DPUs ready for the data centre mainstream?&body=https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/">
                                        <div class="td-social-but-icon"><i class="td-icon-mail"></i></div>
                                        <div class="td-social-but-text">Email</div>
                                    </a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_uid_5_5eceba2c4778d">
                                    <div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
                                </a></div></div></div>            <div class="td-block-row td-post-next-prev"><div class="td-block-span6 td-post-prev-post"><div class="td-post-next-prev-content"><span>Previous article</span><a href="https://blocksandfiles.com/2020/05/22/data-storage-digest-arcserve-excelero-wekaio/">Your occasional storage digest including Arcserve, Excelero and WekaIO</a></div></div><div class="td-next-prev-separator"></div><div class="td-block-span6 td-post-next-post"><div class="td-post-next-prev-content"><span>Next article</span><a href="https://blocksandfiles.com/2020/05/27/infinidat-infinibox-5-6-nvme-of-support/">Infinidat &#8216;pours NVMe-oF rocket fuel&#8217; on DRAM caching fire</a></div></div></div>            <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://blocksandfiles.com/author/chris-mellor/">Chris Mellor</a></span></div>            <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Chris Mellor"></span><meta itemprop="datePublished" content="2020-05-26T11:07:44+00:00"><meta itemprop="dateModified" content="2020-05-26T14:33:30+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://blocksandfiles.com/2020/05/26/data-processor-unit-dpu-overview/"/><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://blocksandfiles.com/wp-content/uploads/2018/10/BF-black-300x92.png"></span><meta itemprop="name" content="Blocks and Files"></span><meta itemprop="headline " content="Are DPUs ready for the data centre mainstream?"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://blocksandfiles.com/wp-content/uploads/2020/05/AWS-NItro-architecture.jpg"><meta itemprop="width" content="950"><meta itemprop="height" content="531"></span>        </footer>

    </article> <!-- /.post -->

    <div class="td_block_wrap td_block_related_posts td_uid_6_5eceba2c47eda_rand td_with_ajax_pagination td-pb-border-top td_block_template_8"  data-td-block-uid="td_uid_6_5eceba2c47eda" ><script>var block_td_uid_6_5eceba2c47eda = new tdBlock();
block_td_uid_6_5eceba2c47eda.id = "td_uid_6_5eceba2c47eda";
block_td_uid_6_5eceba2c47eda.atts = '{"limit":6,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"td_uid_6_5eceba2c47eda_rand","td_column_number":3,"live_filter_cur_post_id":16386,"live_filter_cur_post_author":"6","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"td_uid_6_5eceba2c47eda_rand","tdc_css_class_style":"td_uid_6_5eceba2c47eda_rand_style"}';
block_td_uid_6_5eceba2c47eda.td_column_number = "3";
block_td_uid_6_5eceba2c47eda.block_type = "td_block_related_posts";
block_td_uid_6_5eceba2c47eda.post_count = "6";
block_td_uid_6_5eceba2c47eda.found_posts = "179";
block_td_uid_6_5eceba2c47eda.header_color = "";
block_td_uid_6_5eceba2c47eda.ajax_pagination_infinite_stop = "";
block_td_uid_6_5eceba2c47eda.max_num_pages = "30";
tdBlocksArray.push(block_td_uid_6_5eceba2c47eda);
</script><h4 class="td-related-title td-block-title"><a id="td_uid_7_5eceba2c48c00" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="td_uid_6_5eceba2c47eda" href="#">RELATED ARTICLES</a><a id="td_uid_8_5eceba2c48c04" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="td_uid_6_5eceba2c47eda" href="#">MORE FROM AUTHOR</a></h4><div id=td_uid_6_5eceba2c47eda class="td_block_inner">

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://blocksandfiles.com/2020/05/14/veeam-q12020-customer-numbers/" rel="bookmark" class="td-image-wrap" title="Veeam customer numbers carry on growing"><img width="218" height="150" class="entry-thumb" src="https://blocksandfiles.com/wp-content/uploads/2020/05/shutterstock_field_scream-218x150.jpg" srcset="https://blocksandfiles.com/wp-content/uploads/2020/05/shutterstock_field_scream-218x150.jpg 218w, https://blocksandfiles.com/wp-content/uploads/2020/05/shutterstock_field_scream-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Veeam customer numbers carry on growing"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://blocksandfiles.com/2020/05/14/veeam-q12020-customer-numbers/" rel="bookmark" title="Veeam customer numbers carry on growing">Veeam customer numbers carry on growing</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://blocksandfiles.com/2020/05/14/reader-survey-modernizing-databases/" rel="bookmark" class="td-image-wrap" title="We need you, IT pros. How are you modernizing your databases in a hybrid world?"><img width="218" height="150" class="entry-thumb" src="https://blocksandfiles.com/wp-content/uploads/2020/02/shutterstock_box_dolly-218x150.jpg" srcset="https://blocksandfiles.com/wp-content/uploads/2020/02/shutterstock_box_dolly-218x150.jpg 218w, https://blocksandfiles.com/wp-content/uploads/2020/02/shutterstock_box_dolly-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="We need you, IT pros. How are you modernizing your databases in a hybrid world?"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://blocksandfiles.com/2020/05/14/reader-survey-modernizing-databases/" rel="bookmark" title="We need you, IT pros. How are you modernizing your databases in a hybrid world?">We need you, IT pros. How are you modernizing your databases in a hybrid world?</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://blocksandfiles.com/2020/05/13/commvault-q4fy2020-earnings/" rel="bookmark" class="td-image-wrap" title="Pandemic hits Commvault revenues"><img width="218" height="150" class="entry-thumb" src="https://blocksandfiles.com/wp-content/uploads/2020/05/Commvault-quarterly-revenue-trend-by-fy-218x150.jpg" srcset="https://blocksandfiles.com/wp-content/uploads/2020/05/Commvault-quarterly-revenue-trend-by-fy-218x150.jpg 218w, https://blocksandfiles.com/wp-content/uploads/2020/05/Commvault-quarterly-revenue-trend-by-fy-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Pandemic hits Commvault revenues"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://blocksandfiles.com/2020/05/13/commvault-q4fy2020-earnings/" rel="bookmark" title="Pandemic hits Commvault revenues">Pandemic hits Commvault revenues</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid-->

	<div class="td-related-row">

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://blocksandfiles.com/2020/05/11/quantum-told-to-return-ppp-loan/" rel="bookmark" class="td-image-wrap" title="Quantum asked to return PPP loan, tells B&#038;F: It is &#8216;saving American jobs at Quantum&#8217;"><img width="218" height="150" class="entry-thumb" src="https://blocksandfiles.com/wp-content/uploads/2020/03/shutterstock_coronavirus-218x150.jpg" srcset="https://blocksandfiles.com/wp-content/uploads/2020/03/shutterstock_coronavirus-218x150.jpg 218w, https://blocksandfiles.com/wp-content/uploads/2020/03/shutterstock_coronavirus-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Quantum asked to return PPP loan, tells B&#038;F: It is &#8216;saving American jobs at Quantum&#8217;"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://blocksandfiles.com/2020/05/11/quantum-told-to-return-ppp-loan/" rel="bookmark" title="Quantum asked to return PPP loan, tells B&#038;F: It is &#8216;saving American jobs at Quantum&#8217;">Quantum asked to return PPP loan, tells B&#038;F: It is &#8216;saving American jobs at Quantum&#8217;</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://blocksandfiles.com/2020/05/11/your-occasional-storage-digest-featuring-acronis-dremio-hpe-greenlake-rubrik-polaris-and-panasas/" rel="bookmark" class="td-image-wrap" title="Reader&#8217;s storage digest: Backup, HPC storage, data lakes and more"><img width="218" height="150" class="entry-thumb" src="https://blocksandfiles.com/wp-content/uploads/2020/05/HPC-purchase-criteria-218x150.jpg" srcset="https://blocksandfiles.com/wp-content/uploads/2020/05/HPC-purchase-criteria-218x150.jpg 218w, https://blocksandfiles.com/wp-content/uploads/2020/05/HPC-purchase-criteria-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Reader&#8217;s storage digest: Backup, HPC storage, data lakes and more"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://blocksandfiles.com/2020/05/11/your-occasional-storage-digest-featuring-acronis-dremio-hpe-greenlake-rubrik-polaris-and-panasas/" rel="bookmark" title="Reader&#8217;s storage digest: Backup, HPC storage, data lakes and more">Reader&#8217;s storage digest: Backup, HPC storage, data lakes and more</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 -->

	<div class="td-related-span4">

        <div class="td_module_related_posts td-animation-stack td_mod_related_posts">
            <div class="td-module-image">
                <div class="td-module-thumb"><a href="https://blocksandfiles.com/2020/05/05/cohesity-job-cuts/" rel="bookmark" class="td-image-wrap" title="Cash-rich Cohesity blames pandemic for job cuts"><img width="218" height="150" class="entry-thumb" src="https://blocksandfiles.com/wp-content/uploads/2020/04/Mohit-Cohesity-Headshot2-218x150.jpg" srcset="https://blocksandfiles.com/wp-content/uploads/2020/04/Mohit-Cohesity-Headshot2-218x150.jpg 218w, https://blocksandfiles.com/wp-content/uploads/2020/04/Mohit-Cohesity-Headshot2-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Cash-rich Cohesity blames pandemic for job cuts"/></a></div>                            </div>
            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://blocksandfiles.com/2020/05/05/cohesity-job-cuts/" rel="bookmark" title="Cash-rich Cohesity blames pandemic for job cuts">Cash-rich Cohesity blames pandemic for job cuts</a></h3>            </div>
        </div>
        
	</div> <!-- ./td-related-span4 --></div><!--./row-fluid--></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" id="prev-page-td_uid_6_5eceba2c47eda" data-td_block_id="td_uid_6_5eceba2c47eda"><i class="td-icon-font td-icon-menu-left"></i></a><a href="#"  class="td-ajax-next-page" id="next-page-td_uid_6_5eceba2c47eda" data-td_block_id="td_uid_6_5eceba2c47eda"><i class="td-icon-font td-icon-menu-right"></i></a></div></div> <!-- ./block -->
                                </div>
                            </div>
                            <div class="td-pb-span4 td-main-sidebar" role="complementary">
                                <div class="td-ss-main-sidebar">
                                    <aside class="widget_text td_block_template_8 widget widget_custom_html"><div class="textwidget custom-html-widget"><p style="padding-left:10px"><a href="https://pubads.g.doubleclick.net/gampad/clk?id=5224999888&iu=/6978/textlink"><img src="https://regmedia.co.uk/2020/02/04/komprise_300x100_buttonr3b.png" width=300 height=100 alt="Click Here" title="Komprise_300x100_Button-r2"></a></p></div></aside><div class="td-a-rec td-a-rec-id-custom_ad_1  td_uid_9_5eceba2c4a5c7_rand td_block_template_8"><div id=ad-eagle class=adu>
<script>
  show_gpt('ad-eagle');
</script>
</div></div>                                </div>
                            </div>
                                    </div> <!-- /.td-pb-row -->
    </div> <!-- /.td-container -->
</div> <!-- /.td-main-content-wrap -->

<!-- Instagram -->




	<!-- Footer -->
	<div class="td-footer-wrapper td-container-wrap ">
    <div class="td-container">

	    <div class="td-pb-row">
		    <div class="td-pb-span12">
                <div class="td-a-rec td-a-rec-id-footer_top  td_uid_10_5eceba2c4a7cd_rand td_block_template_8"><span class="td-adspot-title">- Advertisement-</span><div id=ad-owl class=adu>
<script>
  show_gpt('ad-owl');
</script>
</div></div>		    </div>
	    </div>

        <div class="td-pb-row">

            <div class="td-pb-span8">
                <aside class="widget_text td_block_template_8 widget widget_custom_html"><div class="textwidget custom-html-widget"><!-- ADM Smart Pixel - Visited BlocksandFiles - DO NOT MODIFY -->
<script type="text/javascript">!function(a,e,d,m,t){a.adm={};a.adm.pixid=140474;var o=e.getElementsByTagName("head")[0],c=e.createElement("script");a.adm.json="//ps.l.admedo.com/08b52d71-fa24-4046-85d3-ecca0a87401d.json",a.adm.pixurl="//pool.admedo.com",c.src="//pj.l.admedo.com/admtracker.lib.min.js",c.async=!0,o.appendChild(c)}(window,document);</script>
<noscript><img height="1" width="1" style="display:none" src="//pool.admedo.com/pixel?id=140474&t=img" /></noscript>
<!-- End of ADM Smart Pixel --></div></aside>            </div>

            <div class="td-pb-span4">
                            </div>
        </div>
    </div>

    <div class="td-footer-bottom-full">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://blocksandfiles.com/"><img src="https://blocksandfiles.com/wp-content/uploads/2018/10/BF-white-300x92.png" alt="" title=""/></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Blocks & Files is a storage news, information and analysis site covering storage media, devices from drives through arrays to server-based storage, cloud storage, networking and protocols, data management, suppliers and standards. 

We publish news, views, opinions and analysis of storage industry events and developments, aiming to keep storage users, developers, consultants, marketeers, salespeople, support staff, analysts and everyone else involved in IT storage up to date with what’s going on.

</aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://blocksandfiles.com/feed/" title="RSS">
                <i class="td-icon-font td-icon-rss"></i>
            </a>
        </span>
        <span class="td-social-icon-wrap">
            <a target="_blank" href="https://twitter.com/blocksandfiles/" title="Twitter">
                <i class="td-icon-font td-icon-twitter"></i>
            </a>
        </span></aside></div>            </div>
        </div>
    </div>
</div>
	<!-- Sub Footer -->
	    <div class="td-sub-footer-container td-container-wrap ">
        <div class="td-container">
            <div class="td-pb-row">
                <div class="td-pb-span td-sub-footer-menu">
                    <div class="menu-td-demo-footer-menu-container"><ul id="menu-td-demo-footer-menu" class="td-subfooter-menu"><li id="menu-item-248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-248"><a href="https://blocksandfiles.com/about/">About</a></li>
<li id="menu-item-246" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-246"><a href="https://blocksandfiles.com/contribute/">Contribute</a></li>
<li id="menu-item-247" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-247"><a href="https://blocksandfiles.com/contact-us/">Contact us</a></li>
<li id="menu-item-245" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-245"><a href="https://blocksandfiles.com/privacy/">Privacy</a></li>
<li id="menu-item-252" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-252"><a href="https://blocksandfiles.com/cookies/">Cookies</a></li>
<li id="menu-item-253" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-253"><a href="https://blocksandfiles.com/tc/">Ts&#038;Cs</a></li>
<li id="menu-item-13467" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-13467"><a href="https://blocksandfiles.com/blocksfiles-privacy-policy-for-california-residents/">Do not sell my personal information</a></li>
</ul></div>                </div>

                <div class="td-pb-span td-sub-footer-copy">
                    &copy; Situation Publishing, 2018-2020                </div>
            </div>
        </div>
    </div>


</div><!--close td-outer-wrap-->

                <div class="td-more-articles-box">
                    <i class="td-icon-close td-close-more-articles-box"></i>
                    <span class="td-more-articles-box-title">MORE STORIES</span>
                    <div class="td-content-more-articles-box">

                    
        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://blocksandfiles.com/2020/05/27/nvme-universal-block-storage-access-protocol/" rel="bookmark" title="Will NVMe become the universal block storage access protocol?">Will NVMe become the universal block storage access protocol?</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="https://blocksandfiles.com/author/chris-mellor/">Chris Mellor</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-27T12:02:57+00:00" >May 27, 2020</time></span>                    <div class="td-module-comments"><a href="https://blocksandfiles.com/2020/05/27/nvme-universal-block-storage-access-protocol/#respond">0</a></div>                </div>
            </div>

            
        </div>

        
        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://blocksandfiles.com/2020/05/27/infinidat-infinibox-5-6-nvme-of-support/" rel="bookmark" title="Infinidat &#8216;pours NVMe-oF rocket fuel&#8217; on DRAM caching fire">Infinidat &#8216;pours NVMe-oF rocket fuel&#8217; on DRAM caching fire</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="https://blocksandfiles.com/author/chris-mellor/">Chris Mellor</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-27T12:00:00+00:00" >May 27, 2020</time></span>                    <div class="td-module-comments"><a href="https://blocksandfiles.com/2020/05/27/infinidat-infinibox-5-6-nvme-of-support/#respond">0</a></div>                </div>
            </div>

            
        </div>

        
        <div class="td_module_8 td_module_wrap">

            <div class="item-details">
                <h3 class="entry-title td-module-title"><a href="https://blocksandfiles.com/2020/05/22/data-storage-digest-arcserve-excelero-wekaio/" rel="bookmark" title="Your occasional storage digest including Arcserve, Excelero and WekaIO">Your occasional storage digest including Arcserve, Excelero and WekaIO</a></h3>
                <div class="td-module-meta-info">
                                        <span class="td-post-author-name"><a href="https://blocksandfiles.com/author/chris-mellor/">Chris Mellor</a> <span>-</span> </span>                    <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-05-22T14:39:33+00:00" >May 22, 2020</time></span>                    <div class="td-module-comments"><a href="https://blocksandfiles.com/2020/05/22/data-storage-digest-arcserve-excelero-wekaio/#respond">0</a></div>                </div>
            </div>

            
        </div>

                            </div>
                </div>

    <!--

        Theme: Newspaper by tagDiv.com 2017
        Version: 8.7.2 (rara)
        Deploy mode: deploy
        
        uid: 5eceba2c4c92e
    -->

    
<!-- Custom css form theme panel -->
<style type="text/css" media="screen">
/* custom css theme panel */
.td-post-template-6 .td-post-header {
    height: 400px;
}

.td-header-sp-recs {
    text-align: center;
}

.td-module-comments {
    display: none;
}

.td_block_template_8 .td-block-title > *:after {
    display: none;
}


</style>

<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/blocksandfiles.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://blocksandfiles.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript' src='https://blocksandfiles.com/wp-content/themes/Newspaper/js/tagdiv_theme.min.js?ver=8.7.2'></script>
<script type='text/javascript' src='https://blocksandfiles.com/wp-includes/js/comment-reply.min.js?ver=5.4.1'></script>
<script type='text/javascript' src='https://blocksandfiles.com/wp-includes/js/wp-embed.min.js?ver=5.4.1'></script>

<!-- JS generated by theme -->

<script>
    

	

		(function(){
			var html_jquery_obj = jQuery('html');

			if (html_jquery_obj.length && (html_jquery_obj.is('.ie8') || html_jquery_obj.is('.ie9'))) {

				var path = 'https://blocksandfiles.com/wp-content/themes/Newspaper/style.css';

				jQuery.get(path, function(data) {

					var str_split_separator = '#td_css_split_separator';
					var arr_splits = data.split(str_split_separator);
					var arr_length = arr_splits.length;

					if (arr_length > 1) {

						var dir_path = 'https://blocksandfiles.com/wp-content/themes/Newspaper';
						var splited_css = '';

						for (var i = 0; i < arr_length; i++) {
							if (i > 0) {
								arr_splits[i] = str_split_separator + ' ' + arr_splits[i];
							}
							//jQuery('head').append('<style>' + arr_splits[i] + '</style>');

							var formated_str = arr_splits[i].replace(/\surl\(\'(?!data\:)/gi, function regex_function(str) {
								return ' url(\'' + dir_path + '/' + str.replace(/url\(\'/gi, '').replace(/^\s+|\s+$/gm,'');
							});

							splited_css += "<style>" + formated_str + "</style>";
						}

						var td_theme_css = jQuery('link#td-theme-css');

						if (td_theme_css.length) {
							td_theme_css.after(splited_css);
						}
					}
				});
			}
		})();

	
	
</script>



			<div id="tdw-css-writer" style="display: none" class="tdw-drag-dialog tdc-window-sidebar">
				<header>

				
					<a title="Editor" class="tdw-tab tdc-tab-active" href="#" data-tab-content="tdw-tab-editor">Edit with Live CSS</a>
					<div class="tdw-less-info" title="This will be red when errors are detected in your CSS and LESS"></div>
				
				</header>
				<div class="tdw-content">

					
					<div class="tdw-tabs-content tdw-tab-editor tdc-tab-content-active">


						<script>

							(function(jQuery, undefined) {

								jQuery(window).ready(function() {

									if ( 'undefined' !== typeof tdcAdminIFrameUI ) {
										var $liveIframe  = tdcAdminIFrameUI.getLiveIframe();

										if ( $liveIframe.length ) {
											$liveIframe.load(function() {
												$liveIframe.contents().find( 'body').append( '<textarea class="tdw-css-writer-editor" style="display: none"></textarea>' );
											});
										}
									}

								});

							})(jQuery);

						</script>


						<textarea class="tdw-css-writer-editor td_live_css_uid_1_5eceba2c4ca7d"></textarea>
						<div id="td_live_css_uid_1_5eceba2c4ca7d" class="td-code-editor"></div>


						<script>
							jQuery(window).load(function (){

								if ( 'undefined' !== typeof tdLiveCssInject ) {

									tdLiveCssInject.init();


									var editor_textarea = jQuery('.td_live_css_uid_1_5eceba2c4ca7d');
									var languageTools = ace.require("ace/ext/language_tools");
									var tdcCompleter = {
										getCompletions: function (editor, session, pos, prefix, callback) {
											if (prefix.length === 0) {
												callback(null, []);
												return
											}

											if ('undefined' !== typeof tdcAdminIFrameUI) {

												var data = {
													error: undefined,
													getShortcode: ''
												};

												tdcIFrameData.getShortcodeFromData(data);

												if (!_.isUndefined(data.error)) {
													tdcDebug.log(data.error);
												}

												if (!_.isUndefined(data.getShortcode)) {

													var regex = /el_class=\"([A-Za-z0-9_-]*\s*)+\"/g,
														results = data.getShortcode.match(regex);

													var elClasses = {};

													for (var i = 0; i < results.length; i++) {
														var currentClasses = results[i]
															.replace('el_class="', '')
															.replace('"', '')
															.split(' ');

														for (var j = 0; j < currentClasses.length; j++) {
															if (_.isUndefined(elClasses[currentClasses[j]])) {
																elClasses[currentClasses[j]] = '';
															}
														}
													}

													var arrElClasses = [];

													for (var prop in elClasses) {
														arrElClasses.push(prop);
													}

													callback(null, arrElClasses.map(function (item) {
														return {
															name: item,
															value: item,
															meta: 'in_page'
														}
													}));
												}
											}
										}
									};
									languageTools.addCompleter(tdcCompleter);

									window.editor = ace.edit("td_live_css_uid_1_5eceba2c4ca7d");

									// 'change' handler is written as function because it's called by tdc_on_add_css_live_components (of wp_footer hook)
									// We did it to reattach the existing compiled css to the new content received from server.
									window.editorChangeHandler = function () {
										//tdwState.lessWasEdited = true;

										window.onbeforeunload = function () {
											if (tdwState.lessWasEdited) {
												return "You have attempted to leave this page. Are you sure?";
											}
											return false;
										};

										var editorValue = editor.getSession().getValue();

										editor_textarea.val(editorValue);

										if ('undefined' !== typeof tdcAdminIFrameUI) {
											tdcAdminIFrameUI.getLiveIframe().contents().find('.tdw-css-writer-editor:first').val(editorValue);

											// Mark the content as modified
											// This is important for showing info when composer closes
                                            tdcMain.setContentModified();
										}

										tdLiveCssInject.less();
									};

									editor.getSession().setValue(editor_textarea.val());
									editor.getSession().on('change', editorChangeHandler);

									editor.setTheme("ace/theme/textmate");
									editor.setShowPrintMargin(false);
									editor.getSession().setMode("ace/mode/less");
									editor.setOptions({
										enableBasicAutocompletion: true,
										enableSnippets: true,
										enableLiveAutocompletion: false
									});

								}

							});
						</script>

					</div>
				</div>

				<footer>

					
						<a href="#" class="tdw-save-css">Save</a>
						<div class="tdw-more-info-text">Write CSS OR LESS and hit save. CTRL + SPACE for auto-complete.</div>

					
					<div class="tdw-resize"></div>
				</footer>
			</div>
			
</body>
</html>